Saturday, December 21, 2013

SUTD students build smart rack that takes in the laundry when it rains


Ah good invention. Can make the invention better by providing IP interface to the smart rack and support SNMP with web interface for remote control and monitoring.
Snmp will be used to poll the status of the smart rack – such as protrude out for drying or retraction for keeping. With Snmp polling, owner can launch his web browser to display its status – by interoperating with the water sensor and light sensor – to monitor whether it is raining, sunlight, retracted rack or protruded rack – via the Internet using his smartphone, tablets or notebooks via 3G/4G or WiFi, or ADSL or cable modem – depending on where he access his internet.
The SNMP polling can be configured with 5 minutes interval polling. To ensure security on SNMP polling, SNMP v2c or SNMP v3 should be used so that SNMP traffic are encrypted. Ensure SNMP are configure for read-only.
The following are command lines to used for SNMP polling :-
For SNMP v2c.
snmp-server community xxxxxx ro
snmp-server host 150.1.1.1 version 2c xxxxxx
snmp-server enable trap
For SNMP v3,
snmp-server community xxxxxx ro
snmp-server host 150.1.1.1 version 3 auth xxxxxx
snmp-server enable trap
User can remotely via the Internet control the protrusion
and retraction of the smart laundry – securely via the SNMP.

Of course must develop the API and SNMP MIBs to interface with the light sensors, water sensors, motor to protrude and retract the smart laundry and html / xml as web pages to be launch by web browsers.
Ha Ha – can I charge 5% of your IPR per each product sold,
if your team successfully file a patent for your product and commercially launch the product? 来糊口。糊口。
Of course, if you want to be even more safe over Internet –
adopt a even safer 。authentication method – the 2FA. (Details on how this can be done, if you are interested to be a R&D partner).
You think baby idea good or not?


I got even a better idea to make your smart rack – even
smarter.
(1) Provision the 1st pole – as Daddy pole – to hang Daddy’s shirt, trousers, pants, socks – and assign “admin rights” to the Daddy – whereby only Daddy can help to collect all the Daddy’s clothing and dump it into the collection basket for daddy when retracting the Daddy’s pole and release the grip for each clothing and drop it into the basket when dry.
(2) Provision the 2nd pole – as Mummy pole – to hang Mummy’s clothings.
(3) Provision the 3rd pole – as Boyboy pole – to hang Boyboy’s clothings.
(4) Provision the 4th pole – as Girlgirl pole – to hang Girlgirl’s clothings.
Now to achieve this :-
Assign VRF (Virtual Routing Forwarding) instance to be a dedicated tunnel to each pole :-
- 1st pole instance = VRF-Daddy-Pole
- 2nd pole instance = VRF-Mummy-Pole
- 3rd pole instance = VRF-Boyboy-Pole
- 4th pole instance = VRF-Girlgirl-Pole
Below is the configuration to assign the relevant VRF :-
ip vrf VRF-Daddy-Pole
rd 100:1
ip vrf VRF-Mummy-Pole
rd 100:2
ip vrf VRF- Boyboy-Pole
rd 100:3
ip vrf VRF- Girlgirl-Pole
rd 100:4
int fa0/0.11
encapsulation dot1q 11
ip vrf forwarding VRF-Daddy-Pole
ip address 11.11.11.11 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 11 md5 xxx
int fa0/0.12
encapsulation dot1q 12
ip vrf forwarding VRF-Daddy-Pole
ip address 12.12.12.12 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 12 md5 xxx
int fa0/0.13
encapsulation dot1q 13
ip vrf forwarding VRF-Mummy-Pole
ip address 13.13.13.13 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 13 md5 xxx
int fa0/0.14
encapsulation dot1q 14
ip vrf forwarding VRF-Mummy-Pole
ip address 14.14.14.14 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 14 md5 xxx
router ospf 11 vrf VRF-Daddy-Pole
network 11.11.11.0 0.0.0.255 area 100
area 100 authentication message-digest
router ospf 12 vrf VRF-Mummy-Pole
network 12.12.12.0 0.0.0.255 area 100
area 100 authentication message-digest
router ospf 13 vrf VRF-Boyboy-Pole
network 13.13.13.0 0.0.0.255 area 100
area 100 authentication message-digest
router ospf 14 vrf VRF-Girlgirl-Pole
network 14.14.14.0 0.0.0.255 area 100
area 100 authentication message-digest
Upon issuing the correct command where each family member with proper sign in with dedicated right to each
dedicated assign tunnel, the correct pole will then be retracted and drop all the clothing sequentially into the right collection basket.
Eg. Daddy sign in with the correct Daddy userid and password, the Daddy pole will be retracted eg. A simple ping
command as follow :-
Daddy :-
ping vrf VRF-Daddy-Pole 11.11.11.11 – tag this command to a API (Application Progran Interface) to the Daddy pole for retraction. When Daddy pole fully retracted, the clip will be
released and drop the Daddy’s clothings to the Daddy
collection basket. Do the same for the rest.
Mummy :-
ping vrf VRF-Mummy-Pole 12.12.12.12
Boyboy :-
ping vrf VRF-Boyboy-Pole 13.13.13.13
Girlgirl :-
ping vrf VRF-Girlgirl-Pole 14.14.14.14
The above R&D effort – only half an hour. So the SUTD team – do you think Baby qualify to be your R&D partner?

The above provide a dedicated secured tunnel per authenticated user. Consider very safe to manage, control and monitor your home laundry – to prevent hackers from masquerading the owner of the clothing and make the laundry go haywire.
Or worst sabo the clothing by doing premature releasing of the clothings and fall out of the flat and drop the clothing downstair – and incur fine for high-rise littering.


To be proactive and to detect hackers from attempting intrusion and probing of the IT Smart Rack network, configure IPS (Intrusion Prevention System) for the Smart Rack as illustrate below (to protect against hackers from attacking for eg. via spyware, virus, network attack, ddos (small scale attack
– big scale attack go by Internet cleanpipe), dos etc) :-
ip ips name ITSmartRackIPS
ip ips signature-category
category adware/spyware all-adware/spyware
category viruses/worms/Trojans
category attack
category ddos
category dos
category alert-severity high
enabled true
event-action deny-attacker-inline
event-action deny-connection-inline
event-action deny-packet-inline
event-action produce-alert
event-action reset-tcp-connection
fidelity-rating 3
With the IPS, hackers can be detected immediately when anomaly start and when attack start. Thus the IT Smart Rack can be detected when hackers start attacking and prevention of attack as well as protection can be accorded by the IPS.
 

SUTD team for the SmartRack can now do a rap :-
Yo yo, Yo yo.
“Baby is here got no worry.
Smart rack has now become IT.
Baby can give IT security.
Internet hackers cannot be naughty.
Police can now 笑咪咪, need not investigate and do OT.
Customers become happy.
Baby now can earn some money & need not go hungry.
你说可以不可以。”
rap rap rap rap ye!


So now IT design is a science or an art neh ?
IT design has now become a science, an art and a rap - ye!
 

No comments:

Post a Comment